Omnibus GitLab 附带的 PostgreSQL 版本

note此表仅列出了包中发生了有关 PostgreSQL 版本的重大更改的 GitLab 版本,而不是全部。

通常,PostgreSQL 版本会随着 GitLab 的主要或次要版本而变化。但是,Omnibus GitLab 的补丁版本有时会更新 PostgreSQL 的补丁级别。

找出每个 Omnibus GitLab 版本随附的 PostgreSQL(和其他组件)版本。

在 PostgreSQL 升级文档中阅读有关更新策略和警告的更多信息。

极狐GitLab 版本 PostgreSQL 版本 新安装的默认版本 升级默认版本 说明
14.1 12.7, 13.3 12.7 12.7 如果不使用 Geo 或 High Availability,则 PostgreSQL 13 可用于全新安装。
14.0 12.7 12.7 12.7 不再支持使用 repmgr 进行 HA 安装,并且将无法升级到 Omnibus GitLab 14.0
13.8 11.9, 12.4 12.4 12.4 软件包升级会为不属于 Geo 或 HA 集群的节点自动执行 PostgreSQL 升级。